Unable to update Plesk 12.5 on Ubuntu 14.04: error processing archive /var/cache/apt/archives/libapache2-mod-proxy-psa_2.4.7-ubuntu14.04.16021710_amd64.deb

Refers to:

  • Plesk 12.5 for Linux

Created:

2016-11-16 13:06:48 UTC

Modified:

2017-02-23 15:00:19 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to update Plesk 12.5 on Ubuntu 14.04: error processing archive /var/cache/apt/archives/libapache2-mod-proxy-psa_2.4.7-ubuntu14.04.16021710_amd64.deb

Symptoms

Unable to install the latest Plesk 12.5 updates on Ubuntu 14.04. The following error appears:

Unpacking libapache2-mod-proxy-psa (2.4.7-ubuntu14.04.16021710) over (2.4.7-ubuntu14.04.15072015) ...
dpkg: error processing archive /var/cache/apt/archives/libapache2-mod-proxy-psa_2.4.7-ubuntu14.04.16021710_amd64.deb (--unpack):
trying to overwrite '/usr/lib/apache2/modules/mod_proxy_fcgi.so', which is also in package apache2-bin 2.4.7-1ubuntu4.9
Preparing to unpack .../psa-phpfpm-configurator_1.0.0-ubuntu14.04.build1205160218.11_amd64.deb ...
Unpacking psa-phpfpm-configurator (1.0.0-ubuntu14.04.build1205160218.11) over (1.0.0-ubuntu14.04.build1205150819.14) ...
Errors were encountered while processing:
/var/cache/apt/archives/libapache2-mod-proxy-psa_2.4.7-ubuntu14.04.16021710_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ERROR: An error occurred on attempt to install packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

This is a software issue with internal ID #PPPM-4129 . The issue was fixed in Plesk 12.5 MU #23.

Resolution

If it is still reproduced, as the solution, perform the following:

  1. Remove these packages:

    # dpkg -r psa-phpfpm-configurator
    # dpkg -r libapache2-mod-proxy-psa
  2. Install all the latest updates using the command below:

    # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components
Have more questions? Submit a request
Please sign in to leave a comment.