Upgrade error: YumTestTransactionError.

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Created:

2016-11-16 13:06:41 UTC

Modified:

2016-12-21 19:58:43 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Upgrade error: YumTestTransactionError.

Symptoms

The following error appears during upgrade:

YumTestTransactionError: Test Transaction Errors:   file /etc/httpd/conf.d/php.conf from install of php-5.1.6-44.el5_10.x86_64 conflicts with file from package php53-5.3.3-22.el5_10.x86_64

Or the following one:

YumTestTransactionError: Test Transaction Errors:   file /etc/my.cnf from install of mysql-libs-5.5.45-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.95-5.el5_9.i386

Cause

Packages from third-party repositories conflicting with installed ones.

Resolution

  1. Remove all third-party repositories from /etc/yum.repos.d/ . Keep the required files only:

    autoinstaller-sources.repo
    CentOS-Base.repo
    CentOS-Debuginfo.repo
    CentOS-Media.repo
    CentOS-Vault.repo
  2. Start the upgrade again.

Have more questions? Submit a request
Please sign in to leave a comment.