Applicable to:
- Plesk 12.5 for Linux
- Plesk 12.0 for Linux
Symptoms
License Key upload failed with the following error:
PLESK_ERROR: Error: The license key is invalid. In order to use Plesk, please obtain and install a new valid license key.
The license key is intended only for use with Parallels Plesk operating inside the following virtual environments: Parallels Virtuozzo Containers, VMWare, Microsoft Hyper-V, Xen, KVM, Parallels Server.
Cause
The Plesk service cannot execute a back-end utility or the utility is unable to change some files because of incorrect permissions.
Resolution
-
Connect to the server via SSH
-
Make sure that the following files have proper permissions and owners:
# ls -al /usr/local/psa/admin/sbin/*wrapper
---s--x--- 1 root psaadm 13120 Jun 13 21:51 ./admin/sbin/mod_wrapper
---s--x--- 1 root psaadm 13632 Jun 13 21:51 ./admin/sbin/wrapper -
If you see different permissions or owners, run the commands from the following article Different operations in Plesk fails with error: System error 13: Permission denied to correct them.
-
Remove the
/etc/sw/keys/registry.xml
file.# rm -f /etc/sw/keys/registry.xml
-
Log into Plesk. The
registry.xml
file will be recreated. -
If the issue persists, check the steps in the following article: The license key is intended only for use with Plesk operating inside the following virtual environments
Comments
4 comments
Hi,
i have the same issue in ONYX, will it apply?
Noam
@ Noam, yes it will work for Onyx too, but make sure that you use the correct key in correct environment.
If I do this
root@spiderhost:~# ls -al $PRODUCT_ROOT_D/admin/sbin/*wrapper
ls: cannot access '/admin/sbin/*wrapper': No such file or directory
I am unable to see any such file or directory.
I am continuously getting the Plesk license error even if my license and server both are legitimate.
Please help me to resolve this issue.
Hello, I've updated the article. Please also the following one https://support.plesk.com/hc/en-us/articles/213400389
Please sign in to leave a comment.