Plesk encoding issue after logging in (Class 'cList' not found).

Created:

2016-11-16 13:06:15 UTC

Modified:

2017-04-24 11:57:41 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk encoding issue after logging in (Class 'cList' not found).

Applicable to:

  • Plesk 10.4 for Linux

Symptoms

Plesk shows strange symbols after logging in. The following message is in ' /usr/local/psa/admin/logs/panel.log ':

2013-09-05 14:21:28: (mod_fastcgi.c.2588) FastCGI-stderr: PHP Fatal error:  Class 'cList' not found in /usr/local/psa/admin/plib/class.CPAccessList.php on line 4

Cause

Corrupted ' plesk-core ' package:

# rpm -qa | grep plesk-core

# rpm -V plesk-core-10.13.4-rhel6.build1013111102.18.x86_64 |grep missing
missing /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin/config.sample.inc.php
missing /usr/local/psa/admin/htdocs/enterprise/mobile-manager/web.config
missing /usr/local/psa/admin/htdocs/enterprise/rsession_back_url.php
missing /usr/local/psa/admin/plib/DailyMaintainance/execute-quotacheck.php

Resolution

  1. Back up Plesk databases:

    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` psa > /root/psa.dump2.sql
    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` apsc > /root/apsc.dump2.sql
  2. Check what package is owning ' class.CPAccessList.php ' file:

        # rpm -qf /usr/local/psa/admin/plib/class.CPAccessList.php
    plesk-core-10.13.4-cos5.build1013120126.11
  3. Download the ' plesk-core ' package from http://autoinstall.plesk.com/ as per server and Plesk version.

  4. Reinstall ' plesk-core ' package:

    #rpm -Uvh plesk-core-10.13.4-cos5.build1013120126.11 --force.
Have more questions? Submit a request
Please sign in to leave a comment.