Plesk Upgrade got failed with error 'MSI: Error! The older version of Parallels Panel upgrade assistant cannot be removed'

Created:

2016-11-16 13:06:04 UTC

Modified:

2017-08-16 17:21:25 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk Upgrade got failed with error 'MSI: Error! The older version of Parallels Panel upgrade assistant cannot be removed'

Applicable to:

  • Plesk 11.x for Windows

Symptoms

Plesk upgrade failed with error while upgrading from 11.0.9 to 11.5.30:

'MSI: Error! The older version of Parallels Panel upgrade assistant cannot be removed'

Installing packages
upgrading Upgrade Assistant...
MSI: Error! The older version of Parallels Panel upgrade assistant cannot be removed. Contact your technical support group.
Failed to install 'C:\\ParallelsInstaller\\parallels\\PANEL-WIN_11.5.30\\dist-msi-Microsoft-2003-i386\\upgrade-assist.msi': Fatal error during installation. (Error code 1603)
Error: The installation of the package 'upgrade-assist' failed with code 1603. (upgrade: upgrading Upgrade Assistant...)
Not all packages were installed.
Please, contact product technical support.

Cause

The Plesk autoinstaller had been configured to use custom mirror which does not have upgrade-assist.msi file.

upgrade-assist.msi is missing from Plesk installer packages of current version.

For example, if you are trying to upgrade from Plesk Panel 11.0.9 to Plesk 11.5.30, upgrade-assist.msi (or other packages in error) is missing from "C:\\ParallelsInstaller\\parallels\\PANEL-WIN_11.0.9\\dist-msi-Microsoft-2003-i386" .

Resolution

Make sure that all directories in C:\\ParallelsInstaller\\parallels\\PANEL-WIN_* contain the msi package upgrade-assist.msi

If some directory does not have upgrade-assist.msi package of the same version you can get it from http://autoinstall-win.pp.parallels.com and proceed to upgrade the Plesk.

Have more questions? Submit a request
Please sign in to leave a comment.