Unable to change the password of an MSSQL database user: Test connection to the database server has failed because of network problems

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Created:

2016-11-16 13:04:19 UTC

Modified:

2016-12-21 19:53:12 UTC

0

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Unable to change the password of an MSSQL database user: Test connection to the database server has failed because of network problems

Symptoms

Unable to change the password of MSSQL database user using Plesk. The following error is shown:

    Error: Test connection to the database server has failed because of network problems

Cause

Networking/connection issue or password synchronization.

Resolution

  1. Make sure that MSSQL Server and the SQL browser service are running on the server.

  2. Make sure that you can log in to MSSQL server with the same username (usually it is the "sa" user) and password that is mentioned in Plesk > Tools & Settings > Database Servers > MSSQL server . You can check the connection using SQL Server Management Studio.

  3. Ensure that the "sa" user (or another MSSQL admin user specified in Plesk) is enabled by logging in to MSSQL Server. Check this with SQL Server Management Studio or another MSSQL database Manager.

  4. You should be able to connect to the MSSQL server using the hostname/instance name mentioned in the Plesk > Tools and Settings > Database Servers > MSSQL server

  5. Make sure that port 1433 is open and listening on the MSSQL instance.

  6. Make sure that the "Named Pipes" connection method is enabled in your SQL Server Configuration Manager > Protocols for MSSQLSERVER.

  7. If the password is correct and it is possible to login under this user with SQL Server Management Studio, use the solution #2 from KB213388329 applying it to MSSQL instance instead of MySQL.

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