Plesk pre-upgrade checker shows warning: There are custom web server configuration templates

Created:

2016-11-16 13:03:36 UTC

Modified:

2017-07-12 12:04:44 UTC

3

Was this article helpful?


Have more questions?

Submit a request

Plesk pre-upgrade checker shows warning: There are custom web server configuration templates

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk pre-upgrade checker shows warning:

[INFO] STEP 28: Checking for custom web server configuration templates...
[WARNING] There are custom web server configuration templates at /opt/psa/admin/conf/templates/custom. These custom templates might be incompatible with a new Plesk version, and this might lead to failure to generate web server configuration files.Please check https://support.plesk.com/hc/en-us/articles/213399669 for details.
[INFO] Result: WARNING

Cause

There are custom templates stored in /opt/psa/admin/conf/templates/custom/ directory

Resolution

Depending on the changes that were made in custom templates, upgrade can be performed safely, or not.

Contact Plesk technical support for assistance.

Additional information

To run pre-upgrade checker, download the script from http://autoinstall.plesk.com/<Plesk_version>/examiners/panel_preupgrade_checker.php where is the version of upgraded Plesk.

For example, to check upgrade to Plesk 12.5, the link will be:

# wget http://autoinstall.plesk.com/PSA_12.5.30/examiners/panel_preupgrade_checker.php

Run the script:

# php -d safe_mode=Off panel_preupgrade_checker.php
Have more questions? Submit a request
Please sign in to leave a comment.