Plesk upgrade failed: Package mysql is obsoleted by mysql

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:03:01 UTC

Modified:

2016-12-21 19:50:11 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: Package mysql is obsoleted by mysql

Symptoms

Upgrade of Plesk to 12.x failed with error:

Package mysql is obsoleted by mysql, trying to install mysql-5.5.37-14042516.x86_64 instead
mysql-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql conflicts with mysql
mysql-server-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql-server conflicts with mysql-server
mysql-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql conflicts with mysql
mysql-server-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql-server conflicts with mysql-server
mysql-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql conflicts with mysql
mysql-server-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql-server conflicts with mysql-server
mysql-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql conflicts with mysql
mysql-server-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql-server conflicts with mysql-server
mysql-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql conflicts with mysql
mysql-server-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql-server conflicts with mysql-server
mysql-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql conflicts with mysql
mysql-server-5.5.37-14042516.x86_64 from MYSQL_5_5_37-dist has depsolving problems
--> mysql-server conflicts with mysql-server
Exception: Failed to solve dependencies:
mysql conflicts with mysql
mysql-server conflicts with mysql-server

Cause

mysql-server package for both x32 and x64 architectures is installed on the server. 3rd-party repositories, such as Atomic, can provide a certain package for different architectures. These packages can further conflict with Plesk packages.

Resolution

If mysql-server package was installed from a 3rd-party repository, then plesk-mysql package should be removed:

# yum remove plesk-mysql

Please refer to our documentation for details.

Have more questions? Submit a request
Please sign in to leave a comment.