Error during yum upgrade: "Packages excluded due to repository protections"

Created:

2016-11-16 13:02:53 UTC

Modified:

2017-04-24 11:31:11 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Error during yum upgrade: "Packages excluded due to repository protections"

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Unable to upgrade MySQL from 5.1 to 5.5, the following message appears:

# yum upgrade mysql
....
881 packages excluded due to repository protections
No Packages marked for Update

Cause

Protectbase yum plugin is installed. Some repositories are protected.

Resolution

  1. Check that " protectbase " plugin is installed:

    # rpm -qa | grep protectbase
    yum-plugin-protectbase-1.1.30-30.el6.noarch
  2. Check which repositories are protected in repo files in /etc/yum.repos.d directory:

    # grep -ir protect /etc/yum.repos.d
    /etc/yum.repos.d/rpmforge.repo:protect = 0
    /etc/yum.repos.d/rpmforge.repo:protect = 0
    /etc/yum.repos.d/CentOS-Base.repo:protect=1
    /etc/yum.repos.d/CentOS-Base.repo:protect=1
  3. Change " protect " value to 0 using some text editor (e.g. " vi " or " nano "):

    # grep -ir protect /etc/yum.repos.d
    /etc/yum.repos.d/rpmforge.repo:protect = 0
    /etc/yum.repos.d/rpmforge.repo:protect = 0
    /etc/yum.repos.d/CentOS-Base.repo:protect=0
    /etc/yum.repos.d/CentOS-Base.repo:protect=0
Have more questions? Submit a request
Please sign in to leave a comment.