Sending email via Roundcube fails: SMTP Error (535): Authentication failed

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:02:46 UTC

Modified:

2017-02-23 14:15:36 UTC

2

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Sending email via Roundcube fails: SMTP Error (535): Authentication failed

Symptoms

Unable to send an email message using Roundcube webmail. The following error message occurs in Roundcube web interface:

SMTP Error (535): Authentication failed.

Cause

Incorrect configuration settings.

Resolution

Change Roundcube configuration file in the following way:

  1. Log in to Webmail Service node (by default, webmail clients are installed on Plesk Automation Management node, but webmail can be deployed as a separate node, as described in documentation )

  2. Locate main.inc.php configuration file:

    # rpm -qa|grep roundcube|xargs rpm -ql|grep main.inc.php
    /usr/share/psa-roundcube/config/main.inc.php

If this file cannot be located, open the following one: /usr/share/psa-roundcube/config/defaults.inc.php

  1. Change smtp_user value from the following:
    # grep smtp_user /usr/share/psa-roundcube/config/main.inc.php
    $rcmail_config['smtp_user'] = '%u';

to the one below:

    # grep smtp_user /usr/share/psa-roundcube/config/main.inc.php
$rcmail_config['smtp_user'] = '';

Note that in /usr/share/psa-roundcube/config/defaults.inc.php there is $config parameter instead of $rcmail_config

For Plesk 12 : Roundcube configuration file is /usr/share/psa-roundcube/config/defaults.inc.php .

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