Switching the maildriver from qmail to Postfix using Autoinstaller fails on RHEL/CentOS-6.4

Created:

2016-11-16 13:02:41 UTC

Modified:

2017-08-16 16:01:10 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Switching the maildriver from qmail to Postfix using Autoinstaller fails on RHEL/CentOS-6.4

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Switching the maildriver from qmail to Postfix using Autoinstaller fails on RHEL/CentOS - 6.4 with errors like the following:

Attempt to remove 'plesk-mail-qc-driver' to resolve conflict has succeeded
No package matched to remove: psa-qmail-rblsmtpd-0.88-rhel6.build110120606.19.i386
Attempt to remove 'psa-qmail-rblsmtpd-0.88-rhel6.build110120606.19.i386' to resolve conflict has failed
...
No package matched to remove: 2:psa-qmail-1.03-rhel6.build110120606.19.i386
Attempt to remove '2:psa-qmail-1.03-rhel6.build110120606.19.i386' to resolve conflict has failed
...
Exception: Failed to solve dependencies:
plesk-mail-pc-driver conflicts with psa-qmail-rblsmtpd-0.88-rhel6.build110120606.19.i386
plesk-mail-pc-driver conflicts with 2:psa-qmail-1.03-rhel6.build110120606.19.i386

ERROR: The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

Autoinstaller fails to remove the psa-qmail and psa-qmail-rblsmtpd packages using yum. The problem is with the yum package that was updated in the RHEL/CentOS-6.4 release in updates #132413 .

Workaround

Remove the conflicting psa-qmail and psa-qmail-rblsmtpd packages, ignoring dependencies:

# rpm -e psa-qmail psa-qmail-rblsmtpd --nodeps

After this, run autoinstaller again to install the Postfix component:

# /usr/local/psa/admin/bin/autoinstaller
Have more questions? Submit a request
Please sign in to leave a comment.