ERROR: Currently installed version of product with ID 'plesk' is not available from download site anymore.

Created:

2016-11-16 13:02:40 UTC

Modified:

2017-04-24 11:59:22 UTC

0

Was this article helpful?


Have more questions?

Submit a request

ERROR: Currently installed version of product with ID 'plesk' is not available from download site anymore.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

  1. Plesk update fails with following error:

    ERROR: Currently installed version of product with ID 'plesk' is not available from download site anymore.
    Please upgrade to the next available product version to receive software updates.
  2. Otherwise Plesk update fails with following error:

    ERROR: Currently installed version of product with ID 'plesk' is not available from download site anymore.
    Please upgrade to the next available product version to receive software updates.

    rpmdb: Thread/process 31098/140697983772640 failed: Thread died in Berkeley DB library
    error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
    error: cannot open Packages index using db3 - (-30974)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: Thread/process 31098/140697983772640 failed: Thread died in Berkeley DB library
    error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
    error: cannot open Packages database in /var/lib/rpm

Cause

Not supported version of Plesk is installed.

Resolution

  1. Upgrade Plesk to stable version. Additional information can be obtained from the following KB article: #213408749

  2. Follow steps bellow:

a) Make a backup of /var/lib/rpm :

    # tar cf rpmdb.tar /var/lib/rpm

b) Rebuild the rpm db using the following command

    # rpm --rebuilddb

c) Re-run autoinstaller

Have more questions? Submit a request
Please sign in to leave a comment.