Plesk update fails: "Failed to download the package repomd.xml"

Created:

2016-11-16 13:02:33 UTC

Modified:

2017-07-02 22:12:30 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk update fails: "Failed to download the package repomd.xml"

Applicable to:

  • Plesk for Linux
  • Plesk

Symptoms

Plesk update fails with the following error:

File downloading repodata/repomd.xml:
ERROR: Failed to download the package http://mirror.centos.org/centos/5.8/updates/x86_64/repodata/repomd.xml:
The requested URL returned error: 404
Not all packages were installed.

It is not possible to install any Plesk feature, Plesk autoinstaller fails to proceed with the following errors:

 
# plesk installer

WARNING: Ignored deprecated parameter in Plesk Installer's configuration file: 'ADDITIONAL_SOURCE' = 'repodata,500,http://centos.mirror.iweb.com/6/os/x86_64/'
WARNING: Ignored deprecated parameter in Plesk Installer's configuration file: 'ADDITIONAL_SOURCE' = 'repodata,500,http://centos.mirror.iweb.com/6/updates/x86_64/'

ERROR: Syntax error in Plesk Installer's configuration file:
The wrong value 'noSSL_CIPHERS="HIGH:!aNULL:!MD5"' was specified for the parameter 'USE_PLESK_UPDATES'.
You can use only 'yes' or 'no' values with this parameter.

exit status 1

Cause

This issue is caused by an additional source configured in the /root/.autoinstallerrc file.

Resolution

  1. Remove non-working additional sources from the /root/.autoinstallerrc file, or disable them by moving this file:

    # mv /root/.autoinstallerrc /root/.autoinstallerrc.backup
  2. Rerun Plesk autoinstaller.

Have more questions? Submit a request
Please sign in to leave a comment.