Unable to create a backup on network drive: The system cannot find the path specified

Created:

2016-11-16 13:02:26 UTC

Modified:

2017-08-08 13:34:44 UTC

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Unable to create a backup on network drive: The system cannot find the path specified

Applicable to:

  • Plesk for Windows

Symptoms

Unable to create a backup on a network drive:

Backup Manager": Error: (3, 'GetDiskFreeSpace', 'The system cannot find the path specified.').

Cause

Currently, Plesk for Windows supports backup creation on local NTFS partitions and remote FTP servers only. There is a Feature Request with ID #PPPM-4506 , backup creation on network drive is considered to be implemented in future Plesk updates.

Workaround

  1. Disconnect a network drive

  2. Download and extract the process utility PsExec from Microsoft TechNet.

  3. Open cmd.exe and mount a network drive using the following command:

    psexec -s mount -o mtype=hard ip:/path_to_share X:

    where X: is a desired letter for a network drive

  4. Change backup directory location of DUMP_D key in HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Plesk\\PSA Config\\Config registry hive to X:\\ drive

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