Plesk is not accessible: sw-engine-fpm: Cannot load the ionCube PHP Loader

Created:

2016-11-16 13:01:41 UTC

Modified:

2017-08-08 13:44:09 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk is not accessible: sw-engine-fpm: Cannot load the ionCube PHP Loader

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

After a failed upgrade Plesk is not accessible. Attempt to start plesk sw-engine failed with the following error:

Starting sw-engine-fpm: Cannot load the ionCube PHP Loader - it was built with configuration API220121212,NTS, whereas running engine is API220131226,NTS

Cause

Resolution

Edit /usr/local/psa/admin/conf/php.ini , ensure ionCube loader is the same version as in sw-engine package:

For RedHat/CentOS

# rpm -ql sw-engine | grep ioncu
/usr/lib64/php/modules/sw-engine/ioncube_loader_lin_5.6.so

# grep ioncube /usr/local/psa/admin/conf/php.ini
zend_extension = "usr/lib64/php/modules/sw-engine/ioncube_loader_lin_5.6.so"

For Debian/Ubuntu:

# dpkg -L sw-engine | grep ioncu
/usr/lib/x86_64-linux-gnu/php/modules/sw-engine/ioncube_loader_lin_5.6.so

# grep ioncube /usr/local/psa/admin/conf/php.ini
zend_extension = "/usr/lib/x86_64-linux-gnu/php/modules/sw-engine/ioncube_loader_lin_5.6.so"
Have more questions? Submit a request
Please sign in to leave a comment.