SSH Java applet does not work: "SecurityException"

Created:

2016-11-16 13:01:34 UTC

Modified:

2017-05-15 19:03:07 UTC

0

Was this article helpful?


Have more questions?

Submit a request

SSH Java applet does not work: "SecurityException"

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

SSH terminal at Websites & Domains > SSH/Shell Access is showing bank screen or shows one of the following notifications:

SecurityException: com.sun.deploy.net.JARASigningException:
https://x.x.x.x:8443/sshterm/SSHtermApplet-singned.jar

or:

A Plugin is needed to display the content.

Cause

SSH terminal Java applet is incompatible with latest updates of Java runtime. It is not recommended for installation in Plesk 12.x and it is removed from Plesk Onyx. This is an internal issue with ID #PPPM-1039 , which is planned to be fixed in future product updates.

Workaround

Downgrade Java to Java7u40, or:

For Windows-client (works only for Java versions less than Java7u51:

  1. Go to Windows Control Panel > Java > Temporary Internet Files > Settings and switch off Keep temporary files on my computer .

  2. Restart the web browser.

Note : This workaround may not work on all Plesk/Java versions.

Have more questions? Submit a request
Please sign in to leave a comment.