Mail on SSL ports is not working

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:01:00 UTC

Modified:

2016-12-21 19:45:47 UTC

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Mail on SSL ports is not working

Symptoms

Attempts to submit mail via SSL is not working.

Mail client displays the error:

    Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'my email', Server: '3.4.5.6', Protocol: SMTP, Port: 465, Secure(SSL): Yes, Error Number: 0x800CCC0F

At the same time /usr/local/psa/var/log/maillog contain the following error message.

    postfix/smtpd[31990]: warning: TLS library problem: 31990:error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1197:SSL alert number 48:
postfix/smtpd[31990]: lost connection after CONNECT from unknown[1.2.3.4]
postfix/smtpd[31990]: disconnect from unknown[1.2.3.4]

Cause

SSL CA certificates bundle is missing or corrupted.

Resolution

Reinstall CA certificates bundle and then run /usr/local/psa/admin/bin/mchk --without-spam

For example, for CentOS 6:

# rpm -Uhv ca-certificates-2010.63-3.el6_1.5.noarch
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