Scheduled domain level backups rotation does not work - backup files are not being deleted

Created:

2016-11-16 12:59:29 UTC

Modified:

2017-06-23 09:13:50 UTC

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Scheduled domain level backups rotation does not work - backup files are not being deleted

Applicable to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

The scheduled domain level backup rotation does not work. Backup files are not being deleted automatically.

Cause

This behavior is considered to be a software issue. The issue was fixed in Parallels Plesk 11.5 #MU 42 . The internal request ID is PPPM-1556 .

Resolution

Please update Plesk to the latest avaliable microupdate in order to fix the issue. If for some reason you are unable to carry out the update, use the fixed plesk_agent_manager as below:

  1. Back up the original file:

    # cp /usr/local/psa/admin/bin/plesk_agent_manager{,.orig}
  2. Replace the file with the fixed plesk_agent_manager

  3. Make sure that plesk_agent_manager has the correct permissions and ownership:

    # stat /usr/local/psa/admin/bin/plesk_agent_manager
    ...
    Access: (0755/-rwxr-xr-x) Uid: ( 500/ psaadm) Gid: ( 500/ psaadm)

    Change permissions if necessary:

    # chmod 755 /usr/local/psa/admin/bin/plesk_agent_manager
    # chown psaadm:psaadm /usr/local/psa/admin/bin/plesk_agent_manager

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