Applicable to:
- Plesk for Linux
Symptoms
-
When logging in to Plesk or browsing pages in Plesk, one of the following error messages appears:
PLESK_INFO: Type: SWKeyExFatalError
Message: error: Cannot open file: /etc/sw/keys/info
PLESK_INFO: Type: SWKeyExFatalError
Message: error: Cannot create: /etc/sw/keys/lock/repository: Permission denied -
Plesk license installation fails with:
PLESK_INFO: mkstemp failed: /etc/sw/keys/keys/keyXXXXXX: Permission denied (Error code: 2)
Cause
Permissions on the directory /etc/sw/keys
or its subdirectories are incorrect.
Resolution
-
Connect to the Plesk server via SSH.
-
Fix permissions with this command:
# /usr/sbin/usermod -a -G swkey-data psaadm && chown -R root:swkey-data /etc/sw/keys/ && chmod -R 660 /etc/sw/keys/* && chmod -R 644 /etc/sw/keys/info && find /etc/sw/keys -type d -exec chmod 2770 {} \; && chmod 4510 /etc/sw/keys/restart/* && chown -R psaadm:swkey-data /etc/sw/keys/registry.xml /etc/sw/keys/keys/*
-
Restart the Plesk services:
# service sw-engine restart && service sw-cp-server restart
-
Retrieve the Plesk license:
# plesk bin license --retrieve
If the retrieval operation fails, log in to Plesk and install your Plesk license by clicking Install Key.
Comments
4 comments
Hello Dear,
I got same issue but tutorial does not work for me ...
I follow this instructions:
https://support.plesk.com/hc/en-us/articles/213385049-Error-in-Plesk-SWKeyExFatalError-error-Cannot-open-file-
https://support.plesk.com/hc/en-us/articles/213923525-Unable-to-access-activate-Plesk-The-license-key-is-invalid-In-order-to-use-the-Panel-you-need-to-obtain-and-install-a-new-valid-license-key
Main issue:
Could not open Repository at "/etc/sw/keys": Empty repository file: /etc/sw/keys/registry.xml
ERR [panel] Unable to get key: Repository is not opened
It seems that there is no such file and can not write on it.
Someone can please help me ?
Thanks
@Niguleseo
If both these resolution did not help, please submit a request to support to investigate the issue in details: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
Thanks for reply. But can not directly as my licence is sold by a third ...
@Niguleseo
If you have bought a license from Plesk Partner, then you can request for assistance from Partner. You can also buy a support subscription as per https://support.plesk.com/hc/en-us/articles/213953025 and receive support from Plesk directly. It's free for the first month.
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