Cannot upgradePlesk: "file does not exist or is not executable: /usr/local/psa/admin/bin/autoinstaller"

Created:

2016-11-16 12:59:09 UTC

Modified:

2017-08-16 17:40:03 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot upgradePlesk: "file does not exist or is not executable: /usr/local/psa/admin/bin/autoinstaller"

Applicable to:

  • Plesk 10.x for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

I cannot upgrade/update Plesk with error:

    Error message or request description : Error: Unable to start Parallels Products Installer. The following error has occurred: Execution failed. Command: autoinstaller Arguments: Array ( [0] => --service-mode [1] => --enable-xml-output [2] => --ssl-cert [3] => /usr/local/psa/admin/conf/httpsd.pem [4] => --branch [5] => current,release,stable ) Details: file does not exist or is not executable: /usr/local/psa/admin/bin/autoinstaller

Cause

Plesk autoinstaller is corrupted due to previous failed upgrade attempts.

Resolution

  1. Go to http://autoinstall.plesk.com/ in web browser and navigate down the directory structure according to your Plesk version and your operating system version.

  2. In opt/updater subdirectory find psa-autoinstaller package and copy its URI

  3. Download the psa-autoinstaller package from Plesk repository using the URI:

        wget http://autoinstall.plesk.com/<Plesk_version>/<distro_version>/opt/updater/psa-autoinstaller-<version>.rpm
  4. Install the downloaded package:

    rpm -Uvh psa-autoinstaller-<version>.rpm
  5. Re-run Plesk update

Have more questions? Submit a request
Please sign in to leave a comment.