License fails to update

Created:

2016-11-16 12:58:04 UTC

Modified:

2017-07-21 12:18:49 UTC

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License fails to update

Applicable to:

  • Web Presence Builder
  • Plesk
  • Plesk Sitebuilder

 

Symptoms

The product license fails to update. The following errors may occur:

Licensing Server Unreachable: Unable to connect with licensing server.
Please make sure that your network allows communication to ka.plesk.com:5224.
For more details check system help pages.

or

Couldn't resolve host name

or

Can't connect to ka.plesk.com:5224 (Timeout)

Plesk is not accessible:

Error: The licanse key is invalid. in order to use Plesk, please obtain and install a new valid license key. 
Your license key has expired. To continue using your Plesk, you must purchase a non-expiring commercial license key.

Cause

The product tries to connect to the license server ka.plesk.com on TCP port 5224 to update the license, but it cannot establish a connection.

Resolution

On December 1, 2014 , the IP address of the license server was changed to 195.214.233.80 (IPv4) and 2001:67c:730::80 (IPv6). Make sure that the hostname ka.plesk.com resolves to the proper IP from your server:

# nslookup ka.plesk.com
Address: 195.214.233.80

If the license server does not resolve to the correct IP, check the /etc/hosts file.

If any of these servers are behind a firewall and old IP addresses of Key Administrator are listed in the firewall rules, please add new IP addresses of Key Administrator to the firewall rules to allow your servers to connect to ka.plesk.com . This can be checked with these commands, depending on your OS:


Linux:

# nmap -P0 -p5224 ka.plesk.com
# telnet ka.plesk.com 5224
# traceroute ka.plesk.com

Windows:

telnet ka.plesk.com 5224

tracert ka.plesk.com

Note: Telnet client should be installed additionally for Windows -> how to install Telnet client

If APF firewall is used, check /etc/apf/allow_hosts.rules for the mentioned IPs or the hostname ka.plesk.com

IMPORTANT:

If you use any of the following product versions:

  • Plesk for Linux 7.1-8.2.1
  • Sitebuiler for Linux 1.x-2.1.3

and have issues with license update , refer to this article:

  • 213404169 License fails to update or upgrade (legacy product versions)

If the license fails to update on Plesk for Windows 7.5 - 8.x installed on Windows XP/Windows Server 2003 (Microsoft Windows 5.2) , see more details in article

  • 213377529 License for Plesk 7.5/7.6 or 8.x for Windows fails to update

For other products and versions, please see the resolution below.

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