Parallels Plesk GUI can not be accessed after upgrade to 12.0.18

Refers to:

  • Plesk 11.0 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:58:00 UTC

Modified:

2016-12-21 19:39:06 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Parallels Plesk GUI can not be accessed after upgrade to 12.0.18

Symptoms

The issue is related to Ubuntu 12.04.2 x86_64.

After upgrade to Plesk 12, authorisation with correct credentials ends up with nothing but the blank page or error 500.

Panel log (' /usr/local/psa/admin/logs/panel.log ') contains the following output:

[06-Jun-2014 09:13:38 America/New_York] PHP Warning: require_once(interfaces/VirusFilter.php): failed to open stream: No such file or directory; File: /opt/psa/admin/plib/registry/VirusFilter/kav.php, Line: 2

[06-Jun-2014 09:13:38 America/New_York] Exception: PHP Warning: require_once(interfaces/VirusFilter.php): failed to open stream: No such file or directory; File: /opt/psa/admin/plib/registry/VirusFilter/kav.php, Line: 2

file: /opt/psa/admin/plib/Smb/Exception/Syntax.php
line: 56
code: 0
trace: #0 /opt/psa/admin/plib/registry/VirusFilter/kav.php(2): Smb_Exception_Syntax::handleError(2, 'require_once(in...', '/opt/psa/admin/...', 2, Array)
#1 /opt/psa/admin/plib/registry/VirusFilter/kav.php(2): require_once()
#2 /opt/psa/admin/plib/interfaces/InterfacesManager.php(150): require_once('/opt/psa/admin/...')
#3 /opt/psa/admin/plib/interfaces/InterfacesManager.php(96): InterfacesManager::_loadImplFile('/opt/psa/admin/...')
#4 /opt/psa/admin/plib/interfaces/InterfacesManager.php(120): InterfacesManager::getImpls('VirusFilter')
#5 /opt/psa/admin/plib/Mail/VirusFilter/Manager.php(57): InterfacesManager::getImplById('VirusFilter', 'drweb')
#6 /opt/psa/admin/plib/registry/EventListener/drweb.php(202): Mail_VirusFilter_Manager->getActiveImpl()
#7 /opt/psa/admin/plib/interfaces/InterfacesManager.php(150): require_once('/opt/psa/admin/...')
#8 /opt/psa/admin/plib/interfaces/InterfacesManager.php(96): InterfacesManager::_loadImplFile('/opt/psa/admin/...')
#9 /opt/psa/admin/plib/interfaces/InterfacesManager.php(136): InterfacesManager::getImpls('EventListener')
#10 /opt/psa/admin/plib/ActionLog.php(609): InterfacesManager::callImpls('EventListener', 'handleEvent', Array)
#11 /opt/psa/admin/plib/ActionLog.php(364): ActionLog->_callEventListeners()
#12 /opt/psa/admin/plib/Application/Web.php(294): ActionLog->submit()
#13 /opt/psa/admin/htdocs/login_up.php3(67): Plesk\\Application_Web->registerSession('admin', '<cp_password>')
#14 {main}

[06-Jun-2014 09:13:40 America/New_York] PHP Fatal error: require_once(): Failed opening required 'interfaces/VirusFilter.php' (include_path='/opt/psa/admin/plib:/opt/psa/admin/externals') in /opt/psa/admin/plib/registry/VirusFilter/kav.php on line 2

Cause

The package psa-kav8 that was in Plesk panel 11.0.9, was not upgraded to psa-kav12.Thus the files related to psa-kav8 remained and cause the conflicts.

Resolution

Upgrade the package manually:

  1. Remove the old package:

    dpkg -P psa-kav8
  2. Download the new one from repository:

        wget http://autoinstall.plesk.com/PSA_12.0.18/dist-deb-Ubuntu-12.04-x86_64/contrib/psa-kav_12.0.18-ubuntu12.04.build1200140529.21_amd64.deb
  3. Install it:

    dpkg -i psa-kav_12.0.18-ubuntu12.04.build1200140529.21_amd64.deb
Have more questions? Submit a request
Please sign in to leave a comment.