IMAP SSL/TLS connection problem

Created:

2016-11-16 12:57:42 UTC

Modified:

2017-04-24 11:29:11 UTC

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IMAP SSL/TLS connection problem

Applicable to:

  • Plesk for Linux

Symptoms

I have a problem with SSL/TSL secured POP3/IMAP connection. My mail client show that connection either reset or timed out. Steps provided in KB 213935425 are not helped. In the maillog file I see one of the following errors:

SSL routines:SSL3_GET_RECORD:wrong version number:s3_pkt

or

error:0906D06C:PEM routines:PEM_read_bio:no start line

Cause

Server certificate is corrupted or unreadable.

Resolution

Make sure that server certificate file defined in TLS_CERTFILE is valid and owned by the root user and the root group and readable only by root user.If the server certificate file start with BEGIN RSA PRIVATE KEY then it should have the following structure

-----BEGIN RSA PRIVATE KEY-----
...
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
...
-----END CERTIFICATE-----
-----BEGIN DH PARAMETERS-----
...
-----END DH PARAMETERS-----
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