Autoinstaller script fails with error: "Failed to run the Yum utility"

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:57:17 UTC

Modified:

2017-01-31 13:17:09 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Autoinstaller script fails with error: "Failed to run the Yum utility"

Symptoms

When the /usr/local/psa/admin/bin/autoinstaller script is launched, the following warning is shown:

WARNING: Third-party Yum repository 'epel' is enabled, installation may fail.

The installation then fails with the following error:

ERROR: Failed to run the Yum utility.
The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

Third-party repositories are not supported in Parallels Plesk 11.0.9. Please refer to article #114499 for details. Atomic and Remi repository support was added from Parallels Plesk 11.5. Please refer to article #213917765 for details.

Resolution

  1. Disable unsupported third-party repositories on the server. Please read 'man 5 yum.conf', particularly the discussion of enabled=0 versus enabled=1. A line containing one of these options is recommended for each repository in each '.conf' file in the '/etc/yum.repos.d/' directory. This allows the administrator to more clearly specify whether a repository is or is not used for packages. After any edits of these files, in order to clear any cached information, and to make sure the changes are immediately recognized as root, run:

    # yum clean all
  2. And run the autoinstaller script to install all the latest Micro-Updates:

     # /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component base
Have more questions? Submit a request
Please sign in to leave a comment.