Plesk upgrade to 11.5 fails on upgrade APSC database: ERROR 1436 Thread stack overrun

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:56:56 UTC

Modified:

2016-12-21 19:36:39 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade to 11.5 fails on upgrade APSC database: ERROR 1436 Thread stack overrun

Symptoms

Plesk upgrade fails on upgrade apsc database with the following error:

    Trying to set up APS controller database... ERROR 1396 (HY000) at line 1: Operation CREATE USER failed for 'apsc'@'localhost'

Or the following error in log:

    ERROR 1436 (HY000) at line 85: Thread stack overrun:  8368 bytes used of a 131072 byte stack, and 128000 bytes needed.  Use 'mysqld -O thread_stack=#' to specify a bigger stack.

Cause

"thread_stack" size is too small in my.ini.

Resolution

  1. Find my.cnf and check size of "thread_stack":
    # cat /etc/mysql/my.cnf |grep thread_stack
    thread_stack = 64K

OR

    # cat /etc/my.cnf |grep thread_stack
thread_stack = 64K
  1. Increase value of "thread_stack" to larger size, example 128K or 256K:

    # cat /etc/mysql/my.cnf |grep thread_stack
    thread_stack = 128K
  2. Restart Mysql server:

    # /etc/init.d/mysqld restart
Have more questions? Submit a request
Please sign in to leave a comment.