Plesk upgrade failed: Failed to solve dependencies

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:56:42 UTC

Modified:

2016-12-21 19:36:00 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed: Failed to solve dependencies

Symptoms

Plesk upgrade failed. After Plesk autoinstaller restart it is not possible to continue it due to error with similar message:

Exception: Failed to solve dependencies:
plesk-web-hosting-12.5.30-cos6.build1205150826.19.x86_64 requires httpd
awstats-7.4-centos6.15081814.noarch requires httpd
psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64 requires httpd
psa-mnemo-4.2.6-cos6.build1205150819.14.noarch requires plesk-mysql-server >= 12.5.30
psa-mod_rpaf-0.6.1-centos6.15081418.x86_64 requires httpd
psa-kronolith-4.2.8-cos6.build1205150819.14.noarch requires plesk-mysql-server >= 12.5.30
plesk-core-12.5.30-cos6.build1205150826.19.x86_64 requires openssh-clients
mod_bw-0.92-15081418.x86_64 requires httpd
mod_cloudflare-1.2.0.2-centos6.15082019.x86_64 requires httpd
plesk-config-troubleshooter-12.5.30-cos6.build1205150826.19.x86_64 requires plesk-mysql-server >= ...
...
ERROR: Failed to execute an external command: exec() operation failed.
Please, contact product technical support.

In /var/log/plesk/install/autoinstaller3.log it is possible to find similar error:

Running rpm_check_debug
Error: Cannot open file /var/cache/yum/x86_64/6/updates/packages/httpd-tools-2.2.15-47.el6.centos.x86_64.rpm: [Errno 2] No such file or directory: '/var/cache/yum/x86_64/6/updates/packages/httpd-tools-2.2.15-47.el6.centos.x86_64.rpm'
Installing: sw-libboost-program-options1.55.0-1.55.0-centos6.14070417.x86_64 [1/200]
......
processTransaction event: 11 (unknown)
processTransaction event: 20 (Check Package Signatures)
processTransaction event: 30 (Running Test Transaction)
processTransaction event: 40 (Running Transaction)
TypeError: an integer is required
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x3750320>> failed, aborting!

The following error may be shown in Plesk interface:

ERROR: PleskDBException: Unable to connect to database: Unknown database 'psa' (Abstract.php:69)

Cause

Package is lost due to yum error.

Resolution

Apply the solution from this article [KB 213363149] Plesk upgrade failed: Failed to solve dependencies

Have more questions? Submit a request
Please sign in to leave a comment.