Unable to access Plesk: Corrupted source code

Created:

2016-11-16 12:56:29 UTC

Modified:

2017-05-17 11:46:43 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Unable to access Plesk: Corrupted source code

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

The following error is show on Plesk login screen:

Corrupted source code

In /var/log/plesk/panel.log the following message appears:

PHP Warning:  hash() expects parameter 2 to be string, array given in /usr/local/psa/admin/plib/auth.php on line 158

Cause

Some of Plesk files are corrupted.

Resolution

Re-install Plesk microupdates:

# plesk installer --select-release-current --reinstall-patch --upgrade-installed-components
Have more questions? Submit a request
Please sign in to leave a comment.