How-To install particluar version of APS application

Created:

2016-11-16 12:56:20 UTC

Modified:

2017-08-16 18:33:51 UTC

0

Was this article helpful?


Have more questions?

Submit a request

How-To install particluar version of APS application

Applicable to:

  • Plesk 10.x for Linux
  • Plesk 11.x for Linux
  • Plesk 11.x for Windows
  • Plesk 10.x for Windows

Symptoms

How to install previous version of APS application?

Resolution

In Plesk 11.5 it is possible to select version to install on domain.

Go to Applications tab inside the subscription, select desired application and click on "Select another version" link in application title:

In previous versions of Plesk only the latest version of the application available in APS Catalog could be installed.

To install custom version of application, follow these steps:

  1. Open " Websites & Domains " on subscription where the application should be installed.

  2. Use the following SQL query to Plesk database to find the id for the application (17 in this example):

How to access Plesk database

    mysql> select id,name,version from smb_apsPackages;
+----+-----------+---------+
| id | name | version |
+----+-----------+---------+
| 9 | joomla | 2.5.6 |
| 16 | joomla | 2.5.7 |
| 17 | joomla | 2.5.8 |
| 18 | joomla | 3.0.2 |
| 19 | WordPress | 3.5.1 |
+----+-----------+---------+
5 rows in set (0.00 sec)

If desired version of the application is missing from the list, go to <http://apscatalog.com>, download required package and upload it at **Tools & Settings > Application Vault**.
  1. To install the application with custom settings open the link ui separate browser tab:

https:// plesk_server_IP :8443/smb/app/eula/metaId/ 17 /advancedInstall/1

To install the application automatically with the default settings open the link:

https:// plesk_server_IP :8443/smb/app/install/metaId/ 17

Have more questions? Submit a request
Please sign in to leave a comment.