Greylisting still checks emails when sender domains are specified in greylisting whitelist

Created:

2016-11-16 12:56:09 UTC

Modified:

2017-04-24 11:33:06 UTC

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Greylisting still checks emails when sender domains are specified in greylisting whitelist

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

  • Greylisting is disabled for a domain in Plesk, but is still working.

  • The example.com domain is added to Greylisting whitelist:

    [root@server ~]# /usr/local/psa/bin/grey_listing --info-server
    ...
    White domains patterns list:
    *.example.com
    *@example.com
    *example.com
    example.com
    ...

    However, Greylisting still checks emails from the specified domain:

    [root@server ~]# tail -fn0 /var/log/maillog
    ...
    postfix/smtpd[5125]: connect from unknown[203.0.113.2]
    postfix/smtpd[5125]: 9F461A061F: client=unknown[203.0.113.2]
    journal: greylisting filter[5130]: Starting greylisting filter...
    /usr/lib64/plesk-9.0/psa-pc-remote[144]: handlers_stderr: DEFER
    /usr/lib64/plesk-9.0/psa-pc-remote[144]: DEFER during call 'grey' handler
    /usr/lib64/plesk-9.0/psa-pc-remote[144]: Message aborted.
    postfix/smtpd[5125]: 9F461A061F: milter-reject: DATA from unknown[203.0.113.2]: 451 4.7.1 Service unavailable - try again later; from=<user@example.com> to=<user@two.example.com> proto=ESMTP helo=<
    unknown>
    postfix/smtpd[5125]: disconnect from unknown[203.0.113.2]

Cause

Domain whitelist settings are not applied. This is Plesk bug with ID #PPPM-4619 which is planned to be fixed in future Plesk updates.

Resolution

As a workaround, add sender domain to server-wide white list:

# /usr/local/psa/bin/grey_listing -u -whitelist add:*@example.com
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