Unable to manage mailboxes: the page hangs

Created:

2016-11-16 12:56:08 UTC

Modified:

2017-04-24 12:07:02 UTC

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Unable to manage mailboxes: the page hangs

Applicable to:

  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows

Symptoms

Unable to create email accounts. The page hangs when trying to load.

Clicking on any mail account will only cause the screen to load endlessly.

Cause

The " spammng.exe " process is stuck.

Resolution

  1. Check the task manager to find the stuck spammng process:

    spammng --train-messages-ham "--mailname=user@example.com" "--filename=D:/Plesk/PrivateTemp/tmpB2D0.tmp"

    ( spammng may hang while checking files in the folder with name that contains apostrophe (') so make that mail account does not have such folders, rename them if needed.)

  2. Kill the spammng process:

    C:\\>taskkill /f /im spammng.exe
  3. Create a database backup:

    "%plesk_dir%\\MySQL\\bin\\mysqldump" -P8306 -uadmin -p<admin_password> psa > psa.dump.sql
  4. Insert the corresponding database records, replacing 'user' and 'example.com' with the correct user and domain names:

    mysql> SET @m_name := 'user';
    mysql> SET @d_name := 'example.com';
    mysql> select @m_id := m.id from domains as d join mail as m on d.id=m.dom_id where mail_name=@m_name and d.name=@d_name;
    mysql> insert into mn_param values (@m_id,'last_spam_train','2014-01-01T07:50:42+00:00');
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