Plesk upgrade fails with an error: php53-common conflicts with php-common

Created:

2016-11-16 12:55:42 UTC

Modified:

2017-08-16 18:26:36 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails with an error: php53-common conflicts with php-common

Applicable to:

  • Plesk for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk upgrade by autoinstaller fails with an error:

Exception: Failed to solve dependencies:
php53-common conflicts with php-common

ERROR: The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

Upgrade fails due to a sfotware issue in psa-php53-configurator package from the Atomic repository. Following command diagnoses this situation:

# rpm -qa | grep psa-php
psa-php5-configurator-1.6.2-cos5.build110120608.16
psa-php53-configurator-1.6.2-1.el5.art

Normally psa-php5-configurator and psa-php53-configurator cannot be installed in same time. The issue is that psa-php53-configurator-1.6.2-1.el5.art has no conflict with psa-php5-configurator package. It is fixed in psa-php53-configurator-1.6.2-2.el5.art package but it is doesn't solve already affected installations.

Resolution

To resolve such an error, please remove the wrong version of psa-php5-configurator from the server and rerun installation:

rpm -ev psa-php53-configurator-1.6.2-1.el5.art
Have more questions? Submit a request
Please sign in to leave a comment.