API response does not contain proper values for the customer' traffic

Refers to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux

Created:

2016-11-16 12:55:30 UTC

Modified:

2016-12-21 19:32:58 UTC

0

Was this article helpful?


Have more questions?

Submit a request

API response does not contain proper values for the customer' traffic

Symptoms

Table psa.ClientsTraffic contains traffic for vendors, not actual customers. When viewing statistics in Parallels Plesk Panel interface, values are presented properly by accumulating values from psa.DomainsTraffic for given customer.

However, when customer statistics is retrieved via API-RPC, methods used to get client's traffic for response still look into table psa.ClientsTraffic , which results in zero traffic values in response.

STEPS TO REPRODUCE

1) Create customer with subscription.

2) Generate traffic on subscription.

3) Run Daily Maintenance script.

4) Request customer's statistics:

<?xml version="1.0" encoding="UTF-8"?>
<packet version="1.6.3.0">
<customer>
<get>
<filter>
<login>customer1</login>
</filter>
<dataset>
<stat/>
</dataset>
</get>
</customer>
</packet>

ACTUAL RESULT

'statistics' values returned by request are going to be zero:

<?xml version="1.0" encoding="UTF-8"?>
<packet version="1.6.3.0">
<customer>
<get>
<result>
<status>ok</status>
<filter-id>customer1</filter-id>
<id>3</id>
<data>
<stat>
<active_domains>5</active_domains>
<subdomains>2</subdomains>
<disk_space>11108352</disk_space>
<postboxs>1</postboxs>
<redirects>0</redirects>
<mail_groups>0</mail_groups>
<mail_resps>0</mail_resps>
<mail_lists>0</mail_lists>
<web_users>0</web_users>
<data_bases>1</data_bases>
<webapps>0</webapps>
<traffic>0</traffic>
<traffic_prevday>0</traffic_prevday>
</stat>
</data>
</result>
</get>
</customer>
</packet>

Cause

Confirmed bug PPPM-308 for Plesk 11.0.9, 11.5 versions

Resolution

Will be fixed in the future releases.

Have more questions? Submit a request
Please sign in to leave a comment.