ModSecurity fails to be installed

Created:

2016-11-16 12:55:09 UTC

Modified:

2017-08-08 13:25:07 UTC

1

Was this article helpful?


Have more questions?

Submit a request

ModSecurity fails to be installed

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

  • The following error is shown in Plesk:

    Failed to install the ModSecurity rule set: modsecurity_ctl failed: gpg: key 4520AFA9: "Atomicorp (Atomicorp Official Signing Key) <support@atomicorp.com>" not changed gpg: Total number processed: 1 gpg: unchanged: 1 gpg: Signature made Wed Sep 30 17:55:51 2015 EDT using RSA key ID 4520AFA9 gpg: Good signature from "Atomicorp (Atomicorp Official Signing Key) <support@atomicorp.com>" gpg: WARNING: This key is not certified with a trusted signature! gpg: There is no indication that the signature belongs to the owner. Primary key fingerprint: 1818 66DF 9DAC A40E 5B42 9B08 FFBD 5D0A 4520 AFA9 TERM environment variable not set. Command '/bin/bash < /tmp/tmpQMI2Uu/aum-plesk-installer' returned non-zero exit status 1 Unable to download tortix rule set
  • Apache configuration is shown is invalid when perform reconfiguration via cli:

    httpd: Syntax error on line 357 of /etc/httpd/conf/httpd.conf: Syntax error on line 13 of /etc/httpd/conf.d/00_mod_security.conf: No matches for the wildcard '00*exclude.conf' in '/etc/httpd/modsecurity.d', failing (use IncludeOptional if required)

Cause

Software issue #PPPM-3734

Workaround

Modify template as following:

cat /etc/httpd/conf.d/00_mod_security.conf

#ATTENTION!
#DO NOT MODIFY THIS FILE BECAUSE IT WAS GENERATED AUTOMATICALLY,
#SO ALL YOUR CHANGES WILL BE LOST THE NEXT TIME THE FILE IS GENERATED.
Have more questions? Submit a request
Please sign in to leave a comment.