Domains are not visible in Plesk

Created:

2016-11-16 12:55:01 UTC

Modified:

2017-08-16 17:20:34 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Domains are not visible in Plesk

Applicable to:

  • Plesk 10.x for Windows
  • Plesk 10.x for Linux
  • Plesk 11.x for Windows
  • Plesk 11.x for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

Domains are not shown on the Domains page in Plesk 10.4 but subscriptions are shown on the Subscriptions page.

The following error is shown in the Error Console ( Mozilla Firefox > Tools >Web Developer > Error Console ):

    Error: item.forwardingUrlHost is null
Source File: https://PLESKHOST:8443/admin/domain/list?context=domains
Line: 200

Cause

Database inconsistency. At least one domain in Plesk contains an invalid forwarding URL configuration:

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -Ne"select d.name, d.htype, f.redirect from domains d, forwarding f where d.id=f.dom_id and f.redirect not like 'http://%'"
+-------------+---------+------------------+
| name | htype | redirect |
+-------------+---------+------------------+
| DOMAIN1.TLD | std_fwd | REALDOMAIN1.TLD/ |
| DOMAIN2.TLD | frm_fwd | REALDOMAIN2.TLD/ |

You may see that the URL does not contain HTTP://

Resolution

This issue has been fixed since Plesk 10.4.4 MU#35. Plesk 11 is not affected.

To manually fix the issue change the URLs for the affected domains in the database using the following steps:

  1. Create a backup of the Plesk database

  2. Run the following queries (replace values accordingly):

    MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa
    mysql> update forwarding set redirect='http://REALDOMAIN1.TLD/' where redirect='REALDOMAIN1.TLD/';
    mysql> update forwarding set redirect='http://REALDOMAIN2.TLD/' where redirect='REALDOMAIN2.TLD/';

In case it does not help please visit this article: 213412269 Domains and subscriptions list is empty

Have more questions? Submit a request
Please sign in to leave a comment.