Plesk 12 auto-update breaks Roundcube webmail: You will need to install PHP >= 5.3.7 in order to use Roundcube webmail

Created:

2016-11-16 12:54:15 UTC

Modified:

2017-04-24 11:18:45 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Plesk 12 auto-update breaks Roundcube webmail: You will need to install PHP >= 5.3.7 in order to use Roundcube webmail

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

After Plesk 12 auto-update Roundcube is not accessible with the following error:

You will need to install PHP >= 5.3.7 in order to use Roundcube webmail.

Cause

Software issue with id #PPPM-3046 ; the fix is included in #MU55 .

Resolution

Install the most recent Plesk microupdates, the issue will be fixed.

Workarounds

As a workaround, change parameter of version_compare() from value 5.3.7 to 5.3.0 in /usr/share/psa-roundcube/index.php as described below:

// check php version
$phpVersion = phpversion();
if (FALSE !== $phpVersion) {
if (version_compare($phpVersion, '5.3.0', '<')) {
print('You will need to install PHP >= 5.3.0 in order to use Roundcube webmail.');
exit(1);
}
}

Another way is to downgrade plesk-roundcube package (example for RHEL 6):

  1. Download Roundcube 1.0.5 package (find the necessary package that fits the distribution on autoinstall.plesk.com):

    # wget http://autoinstall.plesk.com/PSA_12.0.18/dist-rpm-RedHat-el6-x86_64/opt/roundcube/plesk-roundcube-1.0.5-rhel6.build1200150211.14.noarch.rpm
  2. Downgrade Roundcube with the following command:

    # rpm -Uvh --oldpackage plesk-roundcube-1.0.5-rhel6.build1200150211.14.noarch.rpm
  3. Restart psa service:

    # service psa restart
Have more questions? Submit a request
Please sign in to leave a comment.