Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to synchronize a subscription of a reseller with the service plan.
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It is not possible to adjust limit for a subscription. The following message is shown in Plesk:
PLESK_ERROR: Unable to allocate the required amount of resources (15 GB Disk space). Only 12 GB Disk space are available.
OR
PLESK_ERROR: Unable to set the required resource usage limit (15 GB Disk space) because the new value is less than the amount of resources reserved for your customers or used by yourself (12G Disk space)
OR
PLESK_ERROR: Unable to allocate the required amount of resources (2 MySQL databases). Only 0 MySQL databases are available.
- Unable to restore a backup in Plesk > Domains > example.com > Backup Manager with the following error:
PLESK_ERROR: Unable to allocate the required amount of resources (Unlimited Disk space). Only 12 GB Disk space are available.
- Migration of a subscription throws similar warnings in Tools & Settigns > Migration and Transfer Manager > 203.0.113.2 > Overview tab > example.com [Details]:
PLESK_WARN: Plesk restore report problem:
Execution of "C:\Program Files (x86)\Plesk\bin\domain_pref.exe" --update example.com -disk_space_soft -1 -ignore-nonexistent-options failed with return code 1.
Stderr is
An error occurred while updating domain settings: Cannot set limit 'disk_space_soft' value to '-1': Unable to allocate the required amount of resources (Unlimited Disk space). Only 90 GB Disk space are available.
Cause
Reseller is lacking resources.
Resellers have their own resources they can sell, and for this particular reseller overselling is not allowed, therefore it is not possible to increase disk limit for his subscription.
Resolution
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In Plesk go to Resellers > John Doe and click Customize.
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Apply one of the following solutions:
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Increase disk space limit.
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Increase amount of allowed MySQL databases.
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Allow overselling.
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