Unable to update Plesk: ERROR with rpm_check_debug vs depsolve psa-php5-configurator

Created:

2016-11-16 12:51:54 UTC

Modified:

2017-04-24 12:09:20 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to update Plesk: ERROR with rpm_check_debug vs depsolve psa-php5-configurator

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Symptoms

Unable to upgrade Plesk:

Fatal error during packages installation: [u'ERROR with rpm_check_debug vs depsolve:', 'php-pdo is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-gd is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-imap is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-mbstring is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-mysql is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-xml is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', u'Please report this error at http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum']
YumRPMCheckError: [u'ERROR with rpm_check_debug vs depsolve:', 'php-pdo is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-gd is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-imap is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-mbstring is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-mysql is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', 'php-xml is needed by psa-php5-configurator-1.7.0-cos6.build1205150820.19.x86_64', u'Please report this error at http://bugs.centos.org/set_project.php?project_id=16&ref=http://bugs.centos.org/bug_report_page.php?category=yum']

ERROR: Failed to run the Yum utility.
The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

Unresolved dependencies

Resolution

  1. Install all missing packages that are listed in the error:

    # yum install ---enablerepo=extras php-pdo php-gd php-imap php-mbstring php-mysql php-xml

  2. Run Plesk installer again:

    # plesk installer
Have more questions? Submit a request
Please sign in to leave a comment.