Domain files are not accessible: Internal error

Created:

2016-11-16 12:51:38 UTC

Modified:

2017-06-14 10:28:41 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Domain files are not accessible: Internal error

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.5 for Windows

Note: This article has the reference to the issue with the fix available:

  • #PPPM-3718 "File Manager could hang when trying to display the content of a directory containing a big amount of files."
    Fixed in:
Please consider updating your server:

Symptoms

  • Domain files are not accessible from Plesk File Manager. It fails with an error:

    Internal error.
    {"pager":{"pageCount":1,"itemCountPerPage":100000,"first":1,"current":1,"last":1,"pagesInRange":{"1":1},"firstPageInRange":1,"lastPageInRange":1,"currentItemCount":48353,"totalItemCount":48353,"firstItemNumber":1,"lastItemNumber":48353},"state":{"sortField":"name","sortDirection":"up","currentPage":1,"itemsPerPage":100000,"searchFilters":[],"forceShowSearch":false,"currentDir":"\\/httpdocs","currentDirReadonly":false},"data":[{"id":"..","name":"..","modificationTimestamp":"1449387705","modificationDate":"6\\/12\\/2015 05:41","size":"","formatedSize":"","user":"\\"\\"","group":"\\"\\"","filePerms":"--- --- --- ","isDirectory":true,"type":0,"icon":"\\/theme\\/icons\\/16\\/plesk\\/uplevel.png?1430331306"},{"id":"ad","name":"ad","modificationTimestamp":"1449348731","modificationDate":"5\\/12\\/2015 18:52","size":"","formatedSize":"","user":"\\"\\"","group":"\\"\\"","filePerms":"--- --- --- ","isDirectory":true,"type":1,"icon":"\\/theme\\/icons\\/16\\/plesk\\/file-folder.png?1430219208","actions":[{"name":"browse","title":"Abrir no navegador","href":"http:\\/\\/example.com\\/ad","newWindow":true,"classLabel":"ctx-btn-browse"},{"separator":true},{"name":"rename","title":"Renomear","classLabel":"ctx-btn-rename"},{"name":"permissions","title":"Alterar Permiss\\u00f5es","href":"\\/smb\\/file-manager\\/permissions?currentDir=%2Fhttpdocs&file=ad","classLabel":"ctx-btn-permissions"}]},{"id":"aspnet_client","name":"aspnet_client","modificationTimestamp":"1449348730","modificationDate":"5\\/12\\/2015 18:52","size":"","formatedSize":"","user":"\\"\\"","group":"\\"\\"","filePerms":"--- --- --- ","isDirectory":true,"type":1,"icon":"\\/theme\\/icons\\/16\\/plesk\\/file-folder.png?1430219208","actions":[{"name":"browse","title":"Abrir no navegador","href":"http:\\/\\/example.com\\/aspnet_client","newWindow":true,"classLabel":"ctx-btn-browse"},{"separator":true},{"name":"rename","title":"Renomear","classLabel":"ctx-btn-rename"},{"name":"permissions","title":"Alterar

    ERROR: Allowed memory size of 16777216 bytes exhausted (tried to allocate 86 bytes)
  • Several thousands of files in a directory.

Cause

This is a software issue #PPPM-3718 ; the fix is considered to be included in one of the next Plesk updates.

Resolution

As workaround, please do the following:

For Windows

  1. Increase values of the following parameters in %plesk_dir%\\admin\\conf\\php.ini , e.g.:

    post_max_size=2048M
    max_input_vars=5000
    memory_limit=2048M
  2. Restart Plesk website to apply settings:

    plesk repair --stop-plesk-website && plesk repair --start-plesk-website

For Linux

  1. Increase the aforementioned values in /usr/local/psa/admin/conf/php.ini
  2. Restart psa service(recommended):
    service psa restart
Have more questions? Submit a request
Please sign in to leave a comment.