Mail to mail.ru cannot be delivered

Created:

2016-11-16 12:51:33 UTC

Modified:

2017-08-08 13:32:03 UTC

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Mail to mail.ru cannot be delivered

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Mail to mail.ru ( gmail.com , yahoo.com , etc.) account cannot be delivered. The following log in /var/log/maillog :

    Jun 18 02:14:09 hostname postfix/qmgr[850634]: A994C1D21395: from=<user@example.com>, size=594, nrcpt=1 (queue active)
Jun 18 02:14:09 hostname dovecot: imap-login: Login: user=<user@example.com>, method=DIGEST-MD5, rip=::1, lip=::1, mpid=396335, secured, session=<a9Rc/341GQAAAAAAAAAAAAAAAAAAAAAB>
Jun 18 02:14:10 hostname postfix/pipe[396331]: A994C1D21395: to=<user@mail.ru>, relay=plesk_virtual, delay=0.33, delays=0.27/0.02/0/0.04, dsn=2.0.0, status=sent (delivered via plesk_virtual service)

Cause

There is the same domain mail.ru ( gmail.com , yahoo.com , etc.) created in Plesk, so MTA like Postfix delivers emails locally.

Resolution

Disable mail server for such domain to disable local delivery:

# /usr/local/psa/bin/mail --off example.com

NOTE: It is unsecure to have domains with names that are identical to the domain names of popular online stores and other resources.

To avoid such behavior and prohibit for users to create domains like mail.ru , gmail.com , etc go to Home > Tools & Settings and enable Prohibited Domain Names functionality.

More information can be found int Protection from Mail Interception article.

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