Plesk is not accessible after upgrade: "ssl_ciphers" directive is duplicate

Created:

2016-11-16 12:50:43 UTC

Modified:

2017-04-24 14:16:36 UTC

13

Was this article helpful?


Have more questions?

Submit a request

Plesk is not accessible after upgrade: "ssl_ciphers" directive is duplicate

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux

Symptoms

Unable to access Plesk after upgrade.

Previously [Plesk] CVE-2015-4000 LOGJAM TLS DH vulnerability has been applied on Plesk installation.

Attempt to restart sw-cp-server service results in error:

# service sw-cp-server restart
sw-cp-serverd: nginx: [emerg] "ssl_ciphers" directive is duplicate in /etc/sw-cp-server/conf.d/ssl.conf:1
sw-cp-serverd: nginx: configuration file /etc/sw-cp-server/config test failed

Cause

This is a software issue with internal # PPPM-3228 .

Resolution

Remove /etc/sw-cp-server/conf.d/ssl.conf file and restart sw-cp-server service:

# rm -f /etc/sw-cp-server/conf.d/ssl.conf
# service sw-cp-server restart
Have more questions? Submit a request
Please sign in to leave a comment.