Domain Backup does not run at the scheduled time

Created:

2016-11-16 12:50:34 UTC

Modified:

2017-04-24 12:10:00 UTC

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Domain Backup does not run at the scheduled time

Applicable to:

  • Plesk 12.0 for Windows

Symptoms

  1. Scheduled backup task is defined in Backup Manager however the task itself is not being executed.

  2. "Plesk Scheduler Task #Domain Backup Scheduler <id>" exits with 0xC000142 error code in Windows Task Scheduler.

  3. Task cannot be run from Windows Task Scheduler but runs just fine manually from cmd .

Cause

Windows Task Scheduler misconfiguration. Probably caused by user's custom settings.

Resolution

  1. Navigate to Start > Search > Task Scheduler > Task Scheduler Library and detect the required task. All Plesk scheduled backup tasks have the same name pattern - Plesk Scheduler Task#Domain Backup Scheduler <id> where <id> is an identification value from BackupsScheduled table in Plesk database. Check KB #3472 on how access it.

  2. Te retrieve required information use the queries below:

    mysql> SELECT id, name FROM domains WHERE name LIKE '%domain_name%';

    Remember desired domain's id. It'll correspond to obj_id value from BackupsScheduled table.

    mysql> SELECT id, obj_id, obj_type, active FROM BackupsScheduled WHERE obj_id=<id>;
  3. Make sure that a file with a similar name and .job extension is present in C:\\Windows\\Tasks .

  4. If it's absent perform the following actions to recreate that file:

  5. Remove scheduled task in Plesk Backup Settings

  6. Remove the same instance in Windows Task Scheduler

  7. Create the task again in Plesk

, otherwise go directly to step a

a . Go to Start > Search > Task Scheduler > Task Scheduler Library

b . Plesk Scheduler Task#Domain Backup Scheduler <id>

c . rightclick Properties > General tab > Change user

d . Type Administrator and click Check Names > OK

e . Rerun the task from Task Scheduler or alter the schedule in Plesk to check whether the problem was resolved.

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