Unable to login to Plesk: unknown user name or bad password.

Created:

2016-11-16 12:50:26 UTC

Modified:

2017-05-10 00:08:22 UTC

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Unable to login to Plesk: unknown user name or bad password.

Applicable to:

  • Plesk for Windows

Symptoms

  • The following error appears when attempting to log into Plesk:

    ERROR: Exception
    Unable to logon user (Plesk Administrator): (1326) The user name or password is incorrect.

    OR
    ERROR: Exception: Unable check file existence: Unable to lookup SID for name Plesk Administrator: (1332) No mapping between account names and security IDs was done.<br> at Plesk impersonation(PipeServer::ServerThread::impersonateWithoutProfile line 786)<br> at (zif_plesk_internal_file_exists line 1507)
  • The following error appears when attempting to log into Plesk 17.5:

    ERROR: Exception: Unable to get administrator password: Access is denied. (Error code 5) at Unable to connect to pipe \\.\pipe\P_964acf24-9bd8-4b94-89f7-2c5dc566f924 at (Con::ClientOverlappedPipe::create line 503)
    at getPassword('pwd')(PleskSrvClient::getPassword line 208) at (zif_get_admin_password line 260) Additionally, an exception has occurred while trying to report this error: Zend_Exception No entry is registered for key 'translate' (Helper.php:68)
  • The following error can be seen in the Event Viewer:

    Unhanded exception
    Execute file name: C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\plesksrv.exe
    Unable to thread impersonate run without profile: Unable to logon user (\\Plesk Administrator): (1326) Logon failure: unknown user name or bad password.
    Execute file name: C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\plesksrv.exe

Cause

The psaadm and/or Plesk Administrator users are missing on the server and lacking the necessary permissions.

Resolution

  1. Check if the psaadm or/and Plesk Administrator users exist via Administrative tools > Computer Management > Local Users and Groups > Users .

  2. If one is missing, recreate it: Right Click on the Users > New Users > and specify the following parameters:

    **psaadm**

    User name: psaadm
    Description: Plesk admin account
    Check 'User cannot change password' and 'Password never expires'

    **Plesk Administrator**

    User name: Plesk Administrator
    Description: Plesk Administrator account
    Check 'User cannot change password' and 'Password never expires'
    It should be a member of the Administrators group
  3. Fix permissions with Start > All Programs > Plesk > Plesk Reconfigurator > Check Component and Folder Permissions and Correct disk permissions . Alternatively, you can run the following command in PowerShell:

    PS > & "$env:plesk_bin\\reconfigurator" /check=Accounts,MySQLDataFileSecurity /no-gui
  4. Restart the Plesk Management Service and Plesk SQL Server .

  5. If Plesk is still not accessible, but with the following error:

    Access denied for user 'admin'@'localhost' (using password: YES)

    Then refer to the article ERROR PleskMainDBException Access denied for user 'admin'@'localhost' to reset a password for the admin MySQL user.

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2 Comments

  • 0
    Avatar
    Mkrasx

    In  Plesk version 17.5 it report "Unable to get administrator password". Please modify this article.

    In case of Plesk Reconfigurator -> Repair Plesk installation -> Plesk Server Accounts you can see message:

    Unable to execute "C:\Program Files (x86)\Plesk\admin\bin\usermng.exe" --install-plesk-admin:
    Change flags failed of user (Plesk Administrator): (1322) This operation is disallowed as it could result in an administration account being disabled, deleted or unable to logon.
    at execute console command --install-plesk-admin(vconsoleapp::start line 122)
    at execute "C:\Program Files (x86)\Plesk\admin\bin\usermng.exe" --install-plesk-admin(vconsoleapp::run line 139)

    Edited by Mkrasx
  • 0
    Avatar
    Alexandr Zubtsovsky

    Hello Mkrasx,

    Thank you for your comment.

    We have updated the article according to your report.

    Edited by Alexandr Zubtsovsky
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