Applicable to:
- Plesk for Windows
Symptoms
-
When logging in to Plesk one of the following errors appears in a browser:
PLESK_INFO: ERROR: Exception
Unable to logon user (Plesk Administrator): (1326) The user name or password is incorrect.OR
PLESK_INFO: ERROR: Exception: Unable check file existence: Unable to lookup SID for name Plesk Administrator: (1332) No mapping between account names and security IDs was done.<br> at Plesk impersonation(PipeServer::ServerThread::impersonateWithoutProfile line 786)<br> at (zif_plesk_internal_file_exists line 1507)
OR
PLESK_INFO: ERROR: Exception: Unable to get administrator password: The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\P_4755d610-937d-498b-a70f-6ee61941f472
at (Con::ClientOverlappedPipe::create line 503)
at getPassword('pwd')(PleskSrvClient::getInstance line 334)
at (zif_get_admin_password line 260)OR
PLESK_INFO: ERROR: Exception: Unable to get administrator password: Access is denied. (Error code 5) at Unable to connect to pipe \\.\pipe\P_964acf24-9bd8-4b94-89f7-2c5dc566f924 at (Con::ClientOverlappedPipe::create line 503)
at getPassword('pwd')(PleskSrvClient::getPassword line 208) at (zif_get_admin_password line 260) Additionally, an exception has occurred while trying to report this error: Zend_Exception No entry is registered for key 'translate' (Helper.php:68)OR
PLESK_INFO: ERROR: Uncaught exception 'Exception' with message 'Unable to execute proc_open: The system can not find the file specified. (Error code 2) at Unable to connect to pipe \\\\.\\pipe\\I_3ed9f1e1-4e0e-4d46-a245-8b166434ae88
at (Con::ClientOverlappedPipe::create line 503)
at (zif_plesk_proc_open line 1097)' in C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\common_func.php3:363 Stack trace: #0 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\common_func.php3(363): plesk_proc_open('"C:\\\\Program Fil...', Array, NULL, Array) #1 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\common_func.php3(173): proc_open_exec('"C:\\\\Program Fil...', Array) #2 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\common_func.php3(95): util_exec('send-error-repo...', Array, Array, 'proc_open', 'C:\\\\Program File...') #3 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\Os.php(91): smart_exec('send-error-repo...', Array, 'proc_open') #4 C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\plib\\CommonPanel\\Exception.php(322): Os:: (common_func.php3:363)OR
PLESK_INFO: Unable check file existence: Unable to logon user (SERVER_NAME\Plesk Administrator): (1326) The user name or password is incorrect. at LogonUser(SERVER_NAME\Plesk Administrator)(CClientProfile::logon line 126) at Plesk impersonation(PipeServer::ServerThread::impersonateWithoutProfile line 761) at (zif_plesk_internal_file_exists line 1503) (functions.php:1783)
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The following error can be found in the Event Viewer:
PLESK_INFO: Unhandled exception
Execute file name: C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\plesksrv.exe
Unable to thread impersonate run without profile: Unable to logon user (\\Plesk Administrator): (1326) Logon failure: unknown user name or bad password.
Execute file name: C:\\Program Files (x86)\\Parallels\\Plesk\\admin\\bin\\plesksrv.exeOR
PLESK_INFO: Unable to change the user (Plesk Administrator) password: (2221) Could not find the username.
at serviceMainFunc(plesksrv::serviceMain line 280)
-
When trying to start Plesk Management Service in Plesk Services Monitor, one of the following errors appears:
PLESK_INFO: The process terminated unexpectedly. (Error code 1067) at Start service plesksrv at (service::startStopService line 994)
OR
PLESK_INFO: System error 1067 has occurred
The process terminated unexpectedly.OR
PLESK_INFO: Windows Could not start Plesk Management Service on Local Computer.
Error 1067: The process terminated unexpectedly.
-
When trying to repair Plesk with Plesk Reconfigurator, the following error message is shown:
PLESK_INFO: Unable to execute "C:\Program Files (x86)\Plesk\admin\bin\usermng.exe" --install-plesk-admin:
Change flags failed of user (Plesk Administrator): (1322) This operation is disallowed as it could result in an administration account being disabled, deleted or unable to logon.
at execute console command --install-plesk-admin(vconsoleapp::start line 122)
at execute "C:\Program Files (x86)\Plesk\admin\bin\usermng.exe" --install-plesk-admin(vconsoleapp::run line 139)
Cannot start service plesksrv. System error is: Time out has expired and the operation has not been completed.
Cannot start service PopPassD. System error is: Cannot start service plesksrv. System error is: Time out has expired and the operation has not been completed.
Unable to execute "C:\Program Files (x86)\Plesk\admin\bin\websrvmng.exe" --configure-plesk-website:
The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \\.\pipe\P_6f2c920a-1db3-4b7d-8baf-d029b037caca
at (Con::ClientOverlappedPipe::create line 503)
at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 334)
at execute console command --configure-plesk-website(vconsoleapp::start line 122)
at execute "C:\Program Files (x86)\Plesk\admin\bin64\websrvmng.exe" --configure-plesk-website(vconsoleapp::run line 139)
Cause
The "psaadm" and/or "Plesk Administrator" users are missing on the server or lacking the necessary permissions.
Resolution
-
Connect to a Plesk server via RDP.
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Repair Plesk installation:
2.1. Start Plesk Reconfigurator at Windows Start > All Programs > Plesk or run the command below in a command prompt:
C:\> "%plesk_bin%"\reconfigurator.exe
2.2. In Plesk Reconfigurator, click Repair Plesk installation.
2.3. Select the following:
- Plesk Server Accounts
- Plesk file security
- Plesk Services
2.4. Click Check.
-
Correct permissions by running the following checks one-by-one in Plesk Reconfigurator:
- Correct disk permissions
-
Check Component and Folder Permissions (Note: Select all components from the list)
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Restart the Plesk Management Service and Plesk SQL Server services:
4.1. Start Plesk Services Monitor at Windows Start > All Programs > Plesk.
4.2. In Plesk Services Monitor, check Plesk Management Service and Plesk SQL Server.
4.3. Click Restart.
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Access Plesk.
If Plesk is not accessible with the error below, refer to this KB article for a solution
PLESK_INFO: Access denied for user 'admin'@'localhost' (using password: YES)
Comments
2 comments
In Plesk version 17.5 it report "Unable to get administrator password". Please modify this article.
In case of Plesk Reconfigurator -> Repair Plesk installation -> Plesk Server Accounts you can see message:
Unable to execute "C:\Program Files (x86)\Plesk\admin\bin\usermng.exe" --install-plesk-admin:
Change flags failed of user (Plesk Administrator): (1322) This operation is disallowed as it could result in an administration account being disabled, deleted or unable to logon.
at execute console command --install-plesk-admin(vconsoleapp::start line 122)
at execute "C:\Program Files (x86)\Plesk\admin\bin\usermng.exe" --install-plesk-admin(vconsoleapp::run line 139)
Hello Mkrasx,
Thank you for your comment.
We have updated the article according to your report.
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