[ConnectionOpen (Connect()).]SQL Server does not exist or access denied

Refers to:

  • Plesk
  • MG:5263a535b90b4e98ba1cd10954f080f4
  • MG:e478dfc1817fc00d08cd9e8d5b493880
  • MT:cdf1cf10c248000c36f8aec36a6d5d2a
  • MG:0a372fa971d12dded5db42e5d31f775c
  • MG:b1cdae2ce8d1c095368e668ee65dbd50
  • MG:c18c1648450e3cbe54887675717fb581

Created:

2016-11-16 12:49:56 UTC

Modified:

2017-02-13 06:36:20 UTC

1

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[ConnectionOpen (Connect()).]SQL Server does not exist or access denied

Symptoms

MS SQL server registration in Plesk 11.5 fails on a Windows Server:

    Get database server version failed: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. (Error code 1)

Cause

  1. MS SQL server is not installed.

  2. The SQL Server Authentication mode is only enabled for "Windows Authentication Mode".

  3. An incorrect hostname/instance name is used for MS SQL server.

Resolution

  1. Install the MS SQL server if it is not installed:

    "%plesk_bin%\\ai.exe" --select-product-id panel --select-release-current --show-components

    mssql2008 [up2date] - MSSQL 2008 server
    mssql2008-only [up2date] - MSSQL 2008 server only
    mssql2012 [install] - MSSQL 2012 server
    mssql2012-only [install] - MSSQL 2012 server only

    "%plesk_bin%\\ai.exe" --select-product-id panel --select-release-current --install-component mssql2008-only
  2. Enable "SQL server and Windows Authentication Mode" and retry MS SQL registration in Plesk: http://technet.microsoft.com/en-us/library/ms188670.aspx

  3. Make sure that you can connect to the MS SQL server using the same hostname, user and password that you specify in Plesk Control panel->Tools and Settings->Database Servers. You can check this using MS SQL Server Management Studio or other MS SQL Database Manager.

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