Plesk micro-update installation failure: Sub-process /usr/bin/dpkg returned an error code

Created:

2016-11-16 12:49:30 UTC

Modified:

2017-04-24 12:10:37 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk micro-update installation failure: Sub-process /usr/bin/dpkg returned an error code

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk micro-update installation fails with the following error:

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
---X--- `apt-get` output ---------------------
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
apache2 : Depends: apache2-bin (= 2.4.7-1ubuntu4.8) but 2.4.7-1ubuntu4.5 is to be installed
Depends: apache2-data (= 2.4.7-1ubuntu4.8) but 2.4.7-1ubuntu4.5 is to be installed
linux-image-extra-3.16.0-52-generic : Depends: linux-image-3.16.0-52-generic but it is not going to be installed
linux-image-extra-3.16.0-55-generic : Depends: linux-image-3.16.0-55-generic but it is not going to be installed
linux-image-generic-lts-utopic : Depends: linux-image-3.16.0-55-generic but it is not going to be installed
plesk-php56-fpm : Depends: plesk-php56 (= 5.6.14-ubuntu14.04.15102115) but 5.6.15-ubuntu14.04.15111715 is to be installed

Attempt to correct a system with broken dependencies in place also fails:

# apt-get -f install

Unpacking linux-image-3.16.0-55-generic (3.16.0-55.74~14.04.1) ...
dpkg: error processing archive /var/cache/apt/archives/linux-image-3.16.0-55-generic_3.16.0-55.74~14.04.1_amd64.deb (--unpack):
cannot copy extracted data for './boot/vmlinuz-3.16.0-55-generic' to '/boot/vmlinuz-3.16.0-55-generic.dpkg-new': failed to write (No space left on device)
No apport report written because the error message indicates a disk full error

Insufficient space on /boot partition:

    # df -h /boot
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 236M 234M 0 100% /boot

Cause

Kernel image package cannot be installed due to insufficient space on /boot partition.

Resolution

  1. Increase space on /boot partition

  2. Rerun Plesk autoinstaller

Have more questions? Submit a request
Please sign in to leave a comment.