Horde login error - imp does not provide an authenticate() method.

Created:

2016-11-16 12:49:28 UTC

Modified:

2017-04-24 12:10:39 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Horde login error - imp does not provide an authenticate() method.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 10.x and below for Linux

Symptoms

Horde login form shows an error:

imp does not provide an authenticate() method

Cause

Some Horde files are corrupted or missing.

Resolution

Obtain the list Horde-related packages:

rpm -q psa-horde psa-imp psa-ingo psa-kronolith psa-mnemo psa-passwd psa-turba
psa-horde-5.1.4-cos5.build115130916.13
psa-imp-6.1.4-cos5.build115130916.13
psa-ingo-3.1.2-cos5.build115130916.13
psa-kronolith-4.1.3-cos5.build115130916.13
psa-mnemo-4.1.1-cos5.build115130916.13
psa-passwd-5.0.1-cos5.build115130916.13
psa-turba-4.1.2-cos5.build115130916.13

Get displayed packages from Plesk repository, for example:

~]# wget http://autoinstall.plesk.com/PSA_11.5.30/dist-rpm-RedHat-el5-x86_64/opt/horde/psa-imp-6.0.4-rhel5.build115130628.18

And re-install them:

~]# rpm -Uhv --force psa-imp-6.0.4-rhel5.build115130628.18 <== It can be any other package
Have more questions? Submit a request
Please sign in to leave a comment.