Mailbox usage is incorrectly shown as zero in Plesk

Created:

2016-11-16 12:48:56 UTC

Modified:

2017-04-24 12:10:53 UTC

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Mailbox usage is incorrectly shown as zero in Plesk

Applicable to:

  • Plesk 12.5 for Windows

Symptoms

Mailbox usage for all domains in Plesk is showed as 'zero', but in MailEnable mailbox usage is shown correctly.

Cause

Postoffices path, stored in HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Mail Enable\\Mail Enable\\Connectors\\SF Windows registry key, is set to incorrect directory path.

Resolution

  1. Verify the Mail data root path location set in the registry:

    %plesk_dir%\\admin\\bin>reg query "HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Mail Enable\\Mail Enable" | findstr Root
    Mail Root REG_SZ D:\\Mail_data

    %plesk_dir%\\admin\\bin>reg query "HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Mail Enable\\Mail Enable\\Connectors\\SF" | findstr Root
    Mail Root Directory REG_SZ C:\\Program Files (x86)\\Parallels\\Plesk\\Mail Servers\\Mail Enable\\POSTOFFICES
  2. Correct the Mail root directory to D:\\Mail_Data under the registry path HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Mail Enable\\Mail Enable\\Connectors\\SF .

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