Unable to install Tomcat-Java-Servlets-support. Packages have unmet dependencies.

Refers to:

  • Plesk 12.0 for Linux

Created:

2016-11-16 12:48:48 UTC

Modified:

2016-12-21 19:16:29 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to install Tomcat-Java-Servlets-support. Packages have unmet dependencies.

Symptoms

An installation of Tomcat-Java-Servlets-support by autoinstaller on Debian 6 fails with the following error:

The following packages have unmet dependencies:
psa-tomcat-configurator : Depends: sun-java6-jdk but it is not installable

Cause

Missing the following packages: sun-java6-bin, sun-java6-jdk, sun-java6-jre.

The repository deb http://ftp.de.debian.org/debian squeeze main non-free is missing in sources.list

Resolution

Check for necessary packages for Tomcat Java Servlets support installation

root@localhost:~# dpkg --get-selections | grep sun-java

If there is no packages - add the following repository into /etc/apt/sources.list :

deb http://ftp.de.debian.org/debian squeeze main non-free

Then update & upgrade the server:

root@localhost:~# apt-get update & upgrade

Install Tomcat Java Servlets support by Plesk autoinstaller:

root@localhost:~# plesk installer
Have more questions? Submit a request
Please sign in to leave a comment.