Unable to activate Let's Encrypt: Failed letsencrypt execution

Created:

2016-11-16 12:48:46 UTC

Modified:

2017-04-24 11:33:21 UTC

2

Was this article helpful?


Have more questions?

Submit a request

Unable to activate Let's Encrypt: Failed letsencrypt execution

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Symptoms

Unable to activate Let's Encrypt with the following error:

For Debian:

    Error: Let's Encrypt SSL certificate installation failed: Failed letsencrypt execution: Traceback (most recent call last):
File &quot;/opt/psa/var/modules/letsencrypt/venv/bin/letsencrypt&quot;, line 7, in <module>
from letsencrypt.cli import main
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.5did3/local/lib/python2.7/site-packages/letsencrypt/cli.py&quot;, line 21, in <module>
import OpenSSL
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.5did3/local/lib/python2.7/site-packages/OpenSSL/__init__.py&quot;, line 8, in <module>
from OpenSSL import rand, crypto, SSL
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.5did3/local/lib/python2.7/site-packages/OpenSSL/rand.py&quot;, line 11, in <module>
from OpenSSL._util import (
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.5did3/local/lib/python2.7/site-packages/OpenSSL/_util.py&quot;, line 6, in <module>
from cryptography.hazmat.bindings.openssl.binding import Binding
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.5did3/local/lib/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py&quot;, line 13, in <module>
from cryptography.hazmat.bindings._openssl import ffi, lib
ImportError: /usr/local/psa/var/modules/letsencrypt/venv.5did3/local/lib/python2.7/site-packages/cryptography/hazmat/bindings/_openssl.so: symbol EC_GFp_nistp521_method, version OPENSSL_1.0.1 not defined in file libcrypto.so.1.0.0 with link time reference

For Red-Hat:

Let's Encrypt: Failed letsencrypt execution: Traceback (most recent call last):
File &quot;/usr/local/psa/var/modules/letsencrypt/venv/bin/letsencrypt&quot;, line 11, in <module>
sys.exit(main())
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages/letsencrypt/cli.py&quot;, line 1950, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages/letsencrypt/plugins/disco.py&quot;, line 168, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages/letsencrypt/plugins/disco.py&quot;, line 31, in __init__
self.plugin_cls = entry_point.load()
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages/pkg_resources/__init__.py&quot;, line 2201, in load
self.require(*args, **kwargs)
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages/pkg_resources/__init__.py&quot;, line 2218, in require
items = working_set.resolve(reqs, env, installer)
File &quot;/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages/pkg_resources/__init__.py&quot;, line 835, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (cryptography 1.1 (/usr/local/psa/var/modules/letsencrypt/venv.8VB25/lib/python2.7/site-packages), Requirement.parse('cryptography>=1.3'), set(['PyOpenSSL']))

Cause

Let's Encrypt uses a local python package instead of the system wide one.

Resolution

For Debian:

  1. Update python:

    # apt-get install build-essential libssl-dev libffi-dev python-dev
  2. Upgrade cryptography module:

    # cd /usr/local/psa/var/modules/letsencrypt/venv/bin
    # ./pip install --upgrade cryptography

For Red-Hat:

  1. Update python:

    # yum install gcc libffi-devel python-devel openssl-devel dialog
  2. Upgrade cryptography module:

    # cd /usr/local/psa/var/modules/letsencrypt/venv/bin
    # ./pip install --upgrade cryptography
Have more questions? Submit a request
Please sign in to leave a comment.