Error while creating domain/subdomain: "WebServerManager::addVhost() failed: websrvmng failed: A specified logon session does not exist."

Created:

2016-11-16 12:48:08 UTC

Modified:

2017-05-11 09:40:37 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Error while creating domain/subdomain: "WebServerManager::addVhost() failed: websrvmng failed: A specified logon session does not exist."

Applicable to:

  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

An attempt to create a domain or subdomain on a subscription produces this error:

Error: WebServerManager::addVhost() failed: websrvmng failed: A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520) In Microsoft.Web.Administration module Exception type: System.Runtime.InteropServices.COMException at Microsoft.Web.Administration.Interop.IAppHostMethodInstance.Execute() at Microsoft.Web.Administration.Binding.AddSslCertificate(Byte[] certificateHash, String certificateStoreName) at Microsoft.Web.Administration.BindingManager.BindingTransaction.Commit() at Microsoft.Web.Administration.BindingManager.Save() at Microsoft.Web.Administration.ServerManager.CommitChanges() at ServerManagerFactory.commit() at IIS7ServerManager.commit(IIS7ServerManager* )

The same error may be reported on an attempt to secure a website with an SSL certificate.

Cause

  • The problem may be caused by the wrong SSL certificate being applied to the website, i.e., by the SSL certificate and CA certificate parts being the same.

  • When an SSL certificate is not enabled on a domain in IIS, but SSL is enabled in Parallels Plesk.

Resolution

  1. Go to Home > Domains > example.com > Websites & Domains > Hosting Settings and make sure that SSL is enabled.

  2. Check that the certificate is assigned to the domain in IIS > Sites > example.com > bindings

    IIS binding

  3. On the SSL certificate properties screen ( Websites & Domains tab > Secure Your Sites > Certificate name ), verify that the CA certificate section does not contain the same content as the certificate section above it.

    If the sections match, remove the CA certificate part from the SSL certificate by clicking the Remove button in the CA Certificate section.

  4. If the issue persists, remove all the outdated certificates from Plesk > Tools & Settings > SSL Certificates
Have more questions? Submit a request
Please sign in to leave a comment.